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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to import, solve, and analyze a simple graphics card.

This chapter contains the following topic:

l Sample Project - The Graphics Card

Sample Project - The Graphics Card
In this project, you will learn how to import the graphics card model. Icepak solves conservation
equations of mass, momentum, and energy to provide flow and thermal fields.

Figure 1-1: Graphics Card

Getting Started with Icepak®
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2 - Set Up the Project
This chapter contains the following topics:

l Launch the Ansys Electronics Desktop
l Set Tool Options
l Set Model Units (mm)
l Set the Solution Type

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Getting Started with Icepak®
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. Select the fileGraphics_Card_Geometry.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.

Note: You can hide the grid by selecting View >Grid Settings and then selecting Hide in
theGrid Spacing dialog box. Also, from the View > Coordinate Systemsmenu, you can
hide the large coordinate triad and display a smaller coordinate triad in the bottom of the
3D Modeler window.

Set Up the Project 2-2

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®

Figure 2-1: Graphics Card model in the 3D Modeler window

Note: The region (outer red bounding box), which represents the computational domain,
is automatically created.

3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

4. In the history tree, expandModel > Solids > Air > Region and select Create Region.
5. In the Properties window, note the default X,Y, and Z Padding values.

Note:

Ensure that you enter padding values for -Z Padding Dat before +Z Padding
Data.

Set Up the Project 2-3
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Figure 2-2: Properties Window

6. Expand graphics_card_simple, and review the component geometry in the history tree.

Figure 2-3: History tree

Set Icepak Options
Verify the options under the Toolsmenu as follows:

Set Up the Project 2-4
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1. Click Tools>Options>General Options.
2. Select Icepak and ensure the options are all selected as shown below.

Figure 2-4: Options dialog box

3. Expand Icepak and click Thermal.
4. Ensure that the Use Wizards for data input when creating new boundaries is selec-

ted.

Note: Deselecting the Use Wizards for data input when creating new boundaries
option provides a tabbed dialog box interface as an alternative for creating boundaries.

5. ClickOK to close theOptions dialog box.

Set Model Units (mm)
Define the model units as follows:

1. From theModelermenu, select Units.

The Set Model Units dialog box appears.

2. Selectmm (millimeters) from the Select units drop-down list, and clickOK.

Figure 2-5: Set Model Units dialog box
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Set Solution Type
Specify the design’s solution type as follows:

1. Click Icepak>Solution Type.

The Solution Type dialog box appears.

2. Ensure that Steady State and Temperature and Flow is selected and clickOK.

Figure 2-6: Solution Type

Define Icepak Design Settings
Specify the project design settings as follows:

1. Click Icepak>Design Settings.

The Design Settings dialog box appears.

2. Retain the default settings on the Ambient Conditions,Gravity, Validations, Export
Settings, andMesh tabs and clickOK.

Set Up the Project 2-6
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Figure 2-7: Icepak Design Settings dialog box
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3 - Create and Assign Materials
Materials properties for the components are not defined. For this model, you will create an aniso-
tropic material to be assigned to the PCB component and assign existing materials from the
material library to other components.

Create and Assign an Anisotropic Material
1. In the history tree, right-click on ALPHA_MAIN_PCB and select Assign Material.
2. In the Select Definition dialog box, click Add Material. The View/Edit Material dialog

box appears.
3. In theMaterial Name field, enter PCB_Material.
4. For Thermal Conductivity, click in the Type field and select Anisotropic from the drop-

down list.
5. Enter the following values for the anisotropic tensors:

l T(1,1): 20
l T(2,2): 2
l T(3,3): 20

6. Enter a value of 1 forMass Density, Specific Heat, and Thermal Expansion Coef-
ficient.

Note: Since we are solving a steady-state simulation, these values are just placeholders
and are ignored in the solver.

7. ClickOK to close the View/Edit Material dialog box.
8. ClickOK to assign the newly created material to ALPHA_MAIN_PCB and close the Select

Definition dialog box.

Assign Materials
1. In the history tree, select CPU,Memory1, andMemory1_1 and right-click them.
2. From the right-click menu, select Assign Material.
3. In the Select Definition dialog box, select Ceramic_material.
4. ClickOK to assign the material to the selected components and close the Select Defin-

ition dialog box.
5. In the history tree, select CAPACITOR, CAPACITOR_1, Heat_Sink, KB, and Serial_Port

and right-click them.
6. From the right-click menu, select Assign Material.
7. In the Select Definition dialog box, verify that Al-Extruded is selected.
8. ClickOK to close the Select Definition dialog box.

Getting Started with Icepak®
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9. Select CAPACITOR and CAPACITOR_1.
10. In the Properties window, ensure that the Solve Inside check box is deselected.

Figure 3-1: Solve Inside check box in Properties window

Assign a Surface Material
1. In the history tree, select all of the objects. Right-click on graphics_card_simple and select

Select All.
2. From theModelermenu, select Assign Surface Material to open the Select Definition

dialog box.

Note: You can also open the Select Definition dialog box from the Properties window by
selecting Edit from the Surface Material row Value column drop-down list.

3. In the Select Definition dialog box, verify that Steel-oxidized-surface is selected.
4. ClickOK to close the Select Definition dialog box.
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4 - Prepare and Run the Initial Sim-
ulation

Assign Boundary Conditions
To specify thermal properties to the objects, create boundary conditions. In this example, you'll
create opening, grille, and block boundary conditions.

Assign the Grille, Opening, and Blocks
You'll assign the opening to the minX face of the Region and the grille to the max X face of the
Region.

1. Press F to enter face-selection mode.

2. From the View ribbon, select the Dimetric orientation button from theOrient drop-
down list.

3. Select the max X face of the Region object as displayed below.

Getting Started with Icepak®
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Figure 4-1: Max X face of Region object

4. Right-click and select Assign Thermal>Grille.
5. In theGrille Thermal Model dialog box, enter a Free Area Ratio of 0.8 and clickOK. The

grille boundary condition is added under Thermal in the Project Manager.
6. With the model displayed in the same orientation, hover the cursor over the min X face of

the Region and click.

Figure 4-2: Min X face of Region object

7. The max Y face of the Region is selected. Press B to select the min X face, which was dir-
ectly behind where your cursor was when you made the selection.

Note: You can also right-click and select Next Behind to select a face directly behind your
cursor when you make a selection.

8. Right-click on the selected face and select Assign Thermal>Opening>Free.
9. In theOpening Thermal Model dialog box, select Velocity for Inlet Type, specify an X

Velocity of 2m_per_sec, clickOK.
10. In the history tree, select CPU. Right-click and select Assign Thermal>Block.
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11. In the Block Thermal Model dialog box, enter CPU for the Name, a Total Power of 25
W, and clickOK.

12. In the history tree, selectMemory1 andMemory1_1. Right-click and select Assign
Thermal>Block.

13. In the Block Thermal Model dialog box, enter a Total Power of 5W and clickOK.
14. In the Project Manager, expand Thermal and select Block1.
15. In the Properties window, rename the boundary condition asMemory.

Figure 4-3: Properties window of Memory boundary condition

Add a Solution Setup
Prior to generating a mesh, you must create a solution setup, in which you specify general and
solution settings.

1. In the Project Manager, right-click on Analysis and select Add Solution Setup.
2. In the Icepak Solve Setup Dialog under Flow Regime, select Turbulent and click

Options.
3. In the Turbulent Flow Model dialog box, retain the default selection of Zero Equation

and clickOK.
4. Retain all other default settings on theGeneral, Convergence, and Solver Settings

tabs.
5. ClickOK to save the settings. The solution setup is added under Analysis in the Project

Manager.
6. From the Filemenu, click Save.

Set Up the Project 4-3
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Generate a Global Mesh
When the model geometry is finished, you can mesh the model. In this example, you'll create an
initial global mesh and proceed to solve the model before creating a copy of the Icepak design to
refine the mesh around the HEAT_SINK object.

View Global Mesh Settings
1. In the Project Manager, right-click onMesh and select Edit Global Region.
2. In theMesh Region dialog box, examine the default mesh settings on theGeneral and

Advanced tabs.
3. Retain the default settings and clickOK.

Generate and Examine the Mesh
1. In the Project Manager under Analysis, right-click on the solution setup (Setup1) and

selectGenerate Mesh. When the mesh operation is complete, the mesh loads and the
Mesh visualization dialog box appears.

2. In the history tree, select all geometry under graphics_card_simple.
3. In theMesh visualization dialog box underMesh display on, selectGeo-

metry/Boundary selection to display the mesh for the selected objects.

Set Up the Project 4-4
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Figure 4-4: Mesh on all objects

4. In the history tree, select ALPHA_MAIN_PCB to display mesh only on the PCB.

5. On the View ribbon, click the Right orientation option from theOrient drop-down list.

Figure 4-5: Surface mesh on PCB object
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6. In theMesh visualization dialog box, click theQuality tab and toggle between Face
alignment, Volume, and Skewness, noting theMin andMax values for each.

Note: The following are targets value for face alignment and skewness that increase the
probability of simulation convergence and accurate results.

l Face alignment: >0.05
l Skewness: >0.02

7. Click Close to close theMesh visualization dialog box.

Validate the Project
It is a good practice to validate your project to ensure the model and all settings are within spe-
cified parameters in order to run a simulation.

1. From the Icepakmenu, select Validation Check. The Validation Check dialog is dis-
played and the validations begins. When finished, green check marks appear next to the
project items validated.

Figure 4-6: Validation Check dialog box

2. Click Close to close the Validation Check dialog box.

Create Monitors
Monitor points are useful to display data at a specific point while the solver iterates. In this
example, you'll create monitor points to display temperature data for the CPU and a memory
chip.

Set Up the Project 4-6
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Create Thermal Monitors
Create the CPU Monitor Point

1. In the history tree, right-click on the CPU object and select Assign Monitor>Point. The
Monitor Setup dialog box appears.

Figure 4-7: Monitor Setup dialog box - CPU

2. Enter a Name of CPU_Monitor.
3. Under Thermal, select the Temperature check box.
4. ClickOK. CPU_Monitor1 is created underMonitor in the Project Manager.

Create the Memory Monitor Point
1. In the history tree, right-click on theMemory1 object and select Assign Monitor>Point.

TheMonitor Setup dialog box appears.
2. Enter a Name of Memory_Monitor.
3. Under Thermal, select the Temperature check box.
4. ClickOK.Memory_Monitor1 is created underMonitor in the Project Manager.

Set Up the Project 4-7
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Create a Flow Monitor

1. From the View ribbon, select the Dimetric orientation option from theOrient drop-
down list.

2. Press F to ensure you are in face-selection mode.
3. Select the face of the Region object as displayed below.

Figure 4-8: Region face selection

4. Right-click in the 3D Modeler window, and select Assign Monitor>Point. TheMonitor
Setup dialog box appears.

5. Enter a Name of Exhaust_Monitor.
6. Under Flow, select the Speed check box.
7. ClickOK. Exhaust_Monitor1 is created underMonitor in the Project Manager.

Analyze the Simulation – Initial Global Mesh
Analyze the Model

1. In the Project Manager, right-click on the solution setup (Setup1) and select Analyze to
run the simulation. The status of the simulation is displayed in the progress bar.

2. Right-click on the solution setup (Setup1) and select Residual to open the Solutions dia-
log box.

3. View the residuals update as the simulation runs.

Set Up the Project 4-8
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Note:When the simulation is complete, a message is displayed in theMessage
Manager indicating normal completion.

Figure 4-9: Solutions dialog box - Residual tab

4. Click the Thermal Monitor tab and review the monitor data.

Set Up the Project 4-9
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Figure 4-10: Solutions dialog box - Thermal Monitor tab

5. Click the Flow Monitor tab and review the monitor data.

Set Up the Project 4-10
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Figure 4-11: Solutions dialog box - Flow Monitor tab

Post-process the Results – Initial Global Mesh
Create Surface Plots

1. In the history tree, right-click ALPHA_MAIN_PCB and HEAT_SINK, and select Plot
Fields>Temperature>Temperature.

2. In the Create Field Plot dialog box, retain the default selection of Temperature under
Quantity.

3. Select the Plot on surface only check box and click Done. Temperature contours are dis-
played on the PCB and heat sink objects, and the plot appears under Field Overlays in
the Project Manager.

4. In the 3D Modeler, right-click on the colorkey and selectModify. A dialog box is dis-
played.

5. Click the Scale tab and do the following under Number Format:
l For Type, select Decimal.
l ForWidth, enter 6.

6. Click Save as default and then Close.

Set Up the Project 4-11
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Figure 4-12: PCB and Heatsink temperature contours

Create a Plane
In order to display temperature, pressure, and velocity on a plane cut, you must first create a
plane. The plane will be in the middle of the PCB in the Z direction.

1. From the View ribbon, select click the Dimetric orientation button from theOrient
drop-down list.

2. From the Drawmenu, select Plane.
3. In the 3D Modeler, hover the cursor over the center of the edge of the PCB and click.

Set Up the Project 4-12
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Figure 4-13: Plane creation

4. Hold Z, move the cursor up along the Z plane and click. The new plane displayed under
Planes in the history tree.

Create Plots on a Plane
1. In the history tree, select the plane you created.
2. In the 3D Modeler window, right-click and select Plot Fields>Pressure>Pressure.
3. In the Create Field Plot dialog box, retain the default selection of Pressure underQuant-

ity and click Done. Pressure contours are displayed on the plane.

Note: Click and drag the Pressure colorkey to also display the Temperature colorkey.
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Figure 4-14: Pressure contours on a plane

4. In the Project Manager under Field Overlays, expand Pressure, right-click on the Pres-
sure1 plot and selectModify Plot.

5. In theModify Plot dialog box, select Temperature underQuantity and click Done to dis-
play temperature contours on the plane.
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Figure 4-15: Temperature contours on a plane

6. When you are finished observing the results, expand Temperature in the Project Man-
ager and right-click on Temperature1 and Temperature2 and select Plot Visibility to hide
the plots.

Create a Fields Summary
1. On the Results ribbon, click Fields Summary.
2. In the Setup Calculation dialog under Entity, select Grille1.
3. UnderQuantity, select Speed.
4. Click Add and select Add as a Single Calculation.
5. In the Setup Calculation dialog box, select Volume forGeometry Type.
6. Under Entity, select CPU.
7. UnderQuantity, select Temperature.
8. Click Add and select Add as a Single Calculation.
9. Under Entity, select CPU to clear the selection and then selectMemory.
10. UnderQuantity, select Temperature.
11. Click Add and select Add as a Single Calculation.
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12. Click Close to close the Setup Calculation dialog box. The calculations are displayed in
the Fields Summary dialog box.

13. Click Apply and Export to open the Save As dialog box. Navigate to your working dir-
ectory and click Save to save the fields summary as a comma separated value spread-
sheet.

14. ClickOK to close the Fields Summary dialog box.

Create a Point
1. From the Drawmenu, select Point.
2. Hover the cursor over the center of the grille.
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3. Click to create the point, which appears in the history tree as Point1.

Use the Fields Calculator
1. In the Project Manager, right-click Field Overlays and select Calculator.
2. Under Input, clickQuantity and select Temp.
3. Under Input, clickGeometry.
4. In theGeometry dialog box, select Volume and CPU.
5. Click OK.
6. Under Scalar, click theMin and select Value from the drop-down list.
7. UnderOutput, click Eval. The result of the calculation is displayed in the stack area.
8. Repeats steps 2 through 7 forMax andMean under Scalar.

Note: Mean does not require the selection of Value.

9. Click Add.
10. In the Named Expression dialog box, enter a name for the expression and clickOK. The

expression is saved to the Named Expressions list.
11. Under Input, clickQuantity and select U.
12. In theGeometry dialog box, select Point and then Point1.
13. UnderOutput, click Value and then Eval. The result of the calculation is displayed in the
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stack area.
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Save the Project
From the Filemenu, click Save.
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5 - Refine the Mesh and Run a Sim-
ulation

Copy the Icepak Design
Create a copy of the Icepak design in order to compare the mesh and results of the original
design to the copy with refined mesh.

1. In the Project Manager, right-click on the Icepak design and select Copy.
2. Right-click on the project and select Paste. A copy of the design is placed in the project

folder.

Create a Mesh Region
Now you will create a mesh region around the heat sink to refine the mesh.

Create the Mesh Region
1. PressO to enter object-selection mode.
2. In the 3D Modeler window, select the heatsink.
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Figure 5-1: Heatsink object selection

3. Right-click and select Assign Mesh Region.
4. On the SubRegion dialog box, define padding settings as displayed in the following

image

Refine the Mesh and Run a Simulation 5-2

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®

Figure 5-2: Properties window

5. ClickOK.
6. In theMesh Region dialog box, click OK to accept the default settings and create the

mesh region. The mesh region appears underMesh in the Project Manager, and its geo-
metry is added to the history tree as a non-model box.

Edit Mesh Region Settings
1. In the Project Manager underMesh, double-click onMeshRegion1.
2. In theMesh dialog box, enter a Name of HeatSink.
3. Move the Resolution slider to a finer resolution as displayed below and click OK.
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Figure 5-3: Mesh Regions dialog box

Generate and Examine the Refined Mesh
Generate the mesh and examine the two levels of mesh, those reflecting the global mesh set-
tings and those of the mesh region surrounding the heat sink.

1. In the Project Manager under Analysis, right-click on the solution setup and selectGen-
erate Mesh.When the mesh operation is complete, the mesh loads and theMesh visu-
alization dialog box appears.

Note: In theMesh visualization dialog box underMesh display on, ensure that Show is
enabled.

2. In the history tree, select all geometry under graphics_card_simple.
3. UnderMesh display on, select Show and thenGeometry/Boundary selection to dis-

play the mesh.
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Figure 5-4: Mesh on all objects

4. In the history tree, select ALPHA_MAIN_PCB to display mesh only on the PCB.

5. On the View ribbon, click the Right orientation option from theOrient drop-down list.
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Figure 5-5: Surface mesh on PCB object

Note: Notice the finer resolution within the mesh region surrounding the heat sink.

6. Click Close to close theMesh visualization dialog box.

Analyze the Simulation – Refined Mesh
Analyze the Model

1. In the Project Manager, right-click on the solution setup and select Analyze to run the
simulation. The status of the simulation is displayed in the progress bar.

2. Right-click on the solution setup and select Residual to open the Solutions dialog box.
3. View the residuals update as the simulation runs.

Note:When the simulation is complete, a message is displayed in theMessage
Manager indicating normal completion.
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Figure 5-6: Solutions dialog box - Residual tab

4. Click the Thermal Monitor tab and review the monitor data.
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Figure 5-7: Solutions dialog box - Thermal Monitor tab

5. Click the Flow Monitor tab and review the monitor data.
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Figure 5-8: Solutions dialog box - Flow Monitor tab

Post-process the Results – Refined Mesh
1. In the Project Manager under Field Overlays, select Temperature2, right-click, and

select Plot Visibility.
2. Select Temperature2, right-click, and selectModify Plot.
3. In theModify Plot dialog box underQuantity, select Velocity Vectors.
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Figure 5-9: Temperature and velocity plots

4. Click Done. The temperature and velocity plots are displayed in the 3D Modeler window.

Note: Click and drag the Velocity colorkey to also display the Temperature colorkey.
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Figure 5-10: Temperature and velocity plots

5. When you are finished reviewing the results, expand Temperature in the Project Man-
ager and right-click on Temperature1 and Velocity Vectors1 and select Plot Visibility to
hide the plots.

Compare the Designs
Creating a copy of the original Icepak design within the same Ansys Electronics Desktop project
and using it to refine the mesh allows you to compare the mesh and simulation results. In the
Project Manager, switch between the original Icepak design and the copied design with the
refined mesh region to compare the meshing and simulation results.

Save the Project
From the Filemenu, click Save.
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6 - Run Optimetric Trials
Note:

To run Icepak optimetrics, the Enterprise Electronics license or Optimetrics equivalent
license is required.

Create and Assign Project Variables
You will use the copy of the Icepak design with the refined mesh (IcepakDesign2) to run the opti-
metric trials. Before setting up the optimetrics, create and assign the project variables.

Create Project Variables
1. From the Projectmenu, select Project Variables to open the Properties dialog box.
2. On the Project Variables tab, selectOptimization/Design of Experiments.
3. Click Add to open the Add Property dialog box. Define the settings as follows and then

clickOK.
l Name: $CPU_Power
l Unit Type: Power
l Unit: W
l Value: 25

Figure 6-1: Add Property dialog box

4. Click Add again to open the Add Property dialog box. Define the settings as follows and
then clickOK.

l Name: $Memory_Power
l Unit Type: Power
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l Unit: W
l Value: 5

5. Click Add again to open the Add Property dialog box. Define the settings as follows and
then clickOK.

l Name: $Fan_X
l Unit Type: Speed
l Unit: m_per_sec
l Value: 2

The Properties dialog box now displays the three variables with nominal, minimum, and
maximum values.

Figure 6-2: Properties dialog box with variables

6. Select the Include check box for each variable.
7. ClickOK to close the Properties dialog box.

Assign Project Variables
1. In the Project Manager under Thermal, double-click the CPU boundary condition to open

the Block Thermal Model dialog box.
2. In the Total Power field, enter $CPU_Power and clickOK.

Note: Variable names are case-sensitive. You must enter the name exactly as it
was defined.
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Figure 6-3: Block Thermal Model dialog box with variable

3. In the Project Manager under Thermal, double-click theMemory boundary condition to
open the Block Thermal Model dialog box.

4. In the Total Power field, enter $Memory_Power and clickOK. The Unit field is left blank.
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Figure 6-4: Block Thermal Model dialog box with variable

5. In the Project Manager under Thermal, select theOpening1 boundary condition.
6. In the Properties window, enter $Fan_X in the X Velocity Value field. The Unit field is left

blank.
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Figure 6-5: Opening1 properties with variable

Add a Design of Experiments Setup
1. From the Icepak>Optimetrics Analysismenu, select Add Design of Experiments. to

open the Design of Experiments dialog box.
2. On the Design of Experiments tab, select Central Composite Design from the Design

of Experiments Type drop-down list.
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Figure 6-6: Design of Experiments Setup dialog box - Design of Experiments tab

3. Click the Table tab, and review the trials to be run.
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Figure 6-7: Design of Experiments Setup dialog box - Table tab

4. Click the Calculations tab.
5. Click Setup Calculations.
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Figure 6-8: Design of Experiments Setup dialog box - Calculations tab

6. In the Add/Edit Calculation dialog box, selectMonitor under Category and CPU_Mon-
itor.Temperature underQuantity.

7. Click Add Calculation.

Run Optimetric Trials 6-8

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®

Figure 6-9: Add/Edit Calculation dialog box

8. SelectMemory_Monitor.Temperature underQuantity.
9. Click Add Calculation.
10. Select Exhaust_Monitor.Speed underQuantity and click Add Calculation.
11. Click Done to close the Add/Edit Calculation dialog box.
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Figure 6-10: Design of Experiments Setup dialog box - populated Calculations tab

12. ClickOK to close the Design of Experiment Setup dialog box.

Analyze the Design of Experiments
1. In the Project Manager, expandOptimetrics and right-click DesignOfEx-

perimentsSetup1.
2. From the right-click menu, select Analyze.

Note: Depending on the hardware and licensing configuration, the trials can take upwards
of 15 minutes to complete.

3. After the analysis is complete, right-click DesignOfExperimentsSetup1 and select View
Analysis Result to open the Post Analysis Display dialog box.

l On the Result tab, toggle between the Table and Plot views to display data for each vari-
ation.
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Figure 6-11: Post Analysis Display - Result tab Plot

l Next to View, select Table to review the table displaying data for each variation.

Figure 6-12: Post Analysis Display - Result tab Table
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l On the Response Surface tab, view the data for each variation based on the selection in
the View drop-down list.

l Next to the View drop-down list, click the ... button to open the Response Curves
(2D Slices) dialog box.

Figure 6-13: Response Curves (2D Slices) Properties

l In the Slice Axis field, enter 10.
l Select various configurations for the axes, and use the slider bar to change the
power of the CPU and memory and the speed of the fan. With the Real time mode
check box selected, the response surface is updated automatically. Click Close.
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Figure 6-14: Post Analysis Display - Response Curves (2D Slices)

l From the View drop-down list, select Response Surface to display a 3D response sur-
face.

l Click the ... button to open the Response Surface dialog box.
l Select various configurations for the axes, and use the slider bar to change the power of
the CPU and memory and the speed of the fan. With the Real time mode check box selec-
ted, the response surface is updated automatically.
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Figure 6-15: Post Analysis Display - Response Surface
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